404 on keycloak admin step1.html and step2.html files

i have same issue, and already tried to fix for 3 full days.

i run my admin on a internal different domain to make it not public.

Admin is working (also step1.html) when fully running on main public domain, but when using the internal domain, everything ok except step1 en step2 gives 404…

When i manually change it to the public domain in the browser the step1.html gives 200.

So somehow only these html files don’t work on the internal domain.

also tried:

  • latest keycloak 18.0.1 (quarkus), ,same issue
  • Switch to new admin2 , same issue.
  • tried all ngnix and keycloak options, same issue
  • Also tried to set the KC_HOSTNAME to the main domain and
    KC_SPI_HOSTNAME_DEFAULT_ADMIN to the internal admin domain…
    what happens then is that the admin works but the step html files are working with the public domain (and so is the token endpoint), but that is not what i want , i want to deny the master realm on public domain, and if i do that it’s not working because the html is downloaded from there

Using the developer console of your browser, check the domains used on the requests for step2.

Post them here along with your settings for KC_HOSTNAME_* env or --hostname-*.