Apache webdav using oidc

Hello,
I have configured a working webdav using apache but now I am extending the authentication to use Keycloak oidc.
Following the guide on this page (https://github.com/dcm4che/dcm4chee-arc-light/wiki/Getting-OIDC-Access-Token-using-curl) I have been able to get the token from the client.

When I try to use the token to login to the webdav gives back HTTP code 302.
What is wrong in my configuration? Is it in the Keycloak configuration or the apache?

The commands I use is:

curl -H "Authorization: Bearer $TOKEN" -X PROFIND https://192.168.1.2/webdav/ -H "Depth: 1" --insecure

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>302 Found</title>
</head><body>
<h1>Found</h1>
<p>The document has moved <a href="http://192.168.1.1:8080/auth/realms/example/protocol/openid-connect/auth?response_type=code&amp;scope=openid&amp;client_id=exampleclient&amp;state=uIbkOihCIwugi2xnNcxMCxTsFTA&amp;redirect_uri=https://192.168.1.2/webdav?nonce=XXXXXXXXXXXXXX">here</a>.</p>
</body></html>

My apache configuration looks like this.
> OIDCProviderMetadataURL http://192.168.1.1:8080/auth/realms/example/.well-known/openid-configuration

OIDCClientID exampleclient
OIDCClientSecret 66139c06-57ff-4cfa-acdf-d1dca7024106
OIDCRedirectURI https://192.168.1.2/webdav
OIDCCryptoPassphrase  jj324kl5jkl32BB!

<Location /webdav>
    DAV On
    SSLRequireSSL
    Options None
    AuthType openid-connect
    Require valid-user
</Location>

Using the follow redirect flag in curl like this:
curl -L -H "Authorization: Bearer $TOKEN" -X PROFIND https://192.168.1.2/webdav/ -H "Depth: 1" --insecure

Then I get this error message:

{“error”:“RESTEASY003650: No resource method found for PROFIND, return 405 with Allow header”}