bearerOnly client does not import credential secret

Since we updated to v25.0.1, we noticed that our client marked as bearerOnly is not importing its client secret.

We have our importing client as:

{
“protocol”: “openid-connect”,
“clientId”: “{{ client_back }}”,
“name”: “{{ client_back }}”,
“description”: “{{ client_description }}”,
“enabled”: true,
“publicClient”: false,
“alwaysDisplayInConsole”: false,
“clientAuthenticatorType”: “client-secret”,
“secret”: “{{ backend_clientSecret }}”,
“bearerOnly”: false,
“consentRequired”: false,
“standardFlowEnabled”: false,
“implicitFlowEnabled”: false,
“directAccessGrantsEnabled”: true,
“serviceAccountsEnabled”: true,
“authorizationServicesEnabled”: false
}

We tested to set the bearerOnly to false for the client, and although the secret is being imported the client doesn’t work properly,.

It worked fine on the previous version.

Thanks in advance.

This might help:

Hello dasniko,

We’ve already tried to switch bearerOnly to false. This makes the secret being imported correctly, but the client doesn’t work properly when changing this property.

Any other suggestion?

Thanks in advance.