Bypass Keycloak login form and use directly the IDP login?

Hi to all, I’ve set an identity provider and now in my login page I’ve the choice to authenticate also with the IDP. I would like to use directly the idp page for all the clients.
I’ve try in the authentication flow to set in “Identity Provider Redirector” the Default identity provider


but when I try to login I’ve also the first login page with the IDP choice.

Hpow can use directly the IDP login?

thanks

Have you added the Authenticator workflow to the Client?

Try setting the “Forms”-Authenticator to ALTERNATIVE or DISABLED. Or create a new Flow containing only Cookie and IdP Redirector, and then use that new Flow as default Browser flow.

Yes I’ve added. in fact if I try to change something in the authenticator workflow I can see the effect during the authentication

I’ve try every combination, I’ve also create a new flow but if I disable the forms or I don’t insert it in the new flow I’ve this error:

I’ve try to create a new flow like this:

or modify the default one like this:

But I’ve the previous error.

any idea?

I have a flow which looks exactly like your first screenshot. Are you sure you linked this flow to the browser-Binding? Or configured it as the login flow in the client (section “Authentication Flow Overrides”)?

Yes, I’m sure

in fact switching between SAMLIDP and “original browser” the authentication change, with SAMLIDP I’ve always the previous error. maybe I’m missing something?

I’ve made some test looking logs and I’ve found solution.
I had specified like default identity provider the display name of the IDP and not the alias.

using alias it works fine.

Thanks for support