Disable FullNameMapper

I can’t tell for certain from the documentation, but I get the impression that the FullNameMapper is enabled by default. If I just enter the first and last name during user registration, I’m getting the name attribute also automatically included, concatenating the two, separated by whitespace, which is exactly what the FullNameMapper is doing.

However, first name and last name are western concepts, and I happen to be creating something for an Asian company, and I don’t want a first name to be accidentally set to replace the full name that we are setting ourselves. So I’d love to either disable it. Is that an option?