Disabling cacheThemes and cacheTemplates doesn't work

I’m creating a new custom theme for Keycloak 9.0.0 and have set the following variables in my standalone.xml file.

<staticMaxAge>-1</staticMaxAge>
<cacheThemes>false</cacheThemes>
<cacheTemplates>false</cacheTemplates>

These settings seem to work for most things like styling, images, scripts and some template files.
I seems it’s not working for theme.properties files and some template files.
Editing the template.ftl in a type does seem to work but not other files like login.ftl and other children.
A restart of Keycloak seems to be needed to pick up these changes.

Is there something that I am missing, like an extra setting?
If not, is there a workaround without restarting Keycloak every time?

Thanks in advance.

So, my bad. After bashing into my container and checking the values that where being set I stumbled onto the following.

The Keycloak Docker image uses the standalone-ha.xml as default when starting, so the changes had to be made there.

Everything works now as expected and every file change is immediately picked up.

1 Like

Thank you @zonaut I had the same issue!