Endpoint account/credentials/password not working


In my lab I have running this endpoint: account/credentials/password
I run my Keycloak in:

docker run -p 8080:8080 -e KEYCLOAK_USER=admin -e KEYCLOAK_PASSWORD=admin -e JAVA_OPTS_APPEND="-Dkeycloak.profile.feature.account_api=enabled" jboss/keycloak

and in Swagger I run POST:


and I have a error:

“error”: “RESTEASY003210: Could not find resource for full path: localhost:8080/auth/admin/realms/master/account/credentials/password”

I have a same error, when I run a POST:


Any idea why not working?
The whole thing is described here: json - Is there an API call for changing user password on keycloak? - Stack Overflow

I don’t think that account endpoint is going to exist going forward. It looks like it got removed from the account API (one of the keycloak people can comment here).

If you’re an admin, and want to resent someone’s password, you can use:

PUT http://localhost:8080/auth/admin/realms/master/users/{user_uuid}/reset-password

which takes a payload of:

{type: "password", value: "{password}", temporary: false}

1 Like