Fresh Keycloak 25.0.1: No Username / PW for master realm

Hi!

I recently wanted to migrate a working instance of a KC 24.0.5 Docker-Deployment to KC 25.0.1

However, when I tried to log into the master realm after it finished starting I got a series of unfinished HTML-Pages.

“RESOURCE NOT FOUND”
a neverending “Loading Administration Console”

The only error I see in the console is a weird error message about disallowed mime-types:

The only thing I changed in my docker config was the version number and the keycloak parameters “hostname” and “hostname-admin”, which no longer have an “-url” attached.

I am not sure what is causing this behaviour since I wiped the database so it should be a clean new install of KC.

Has anyone experienced simililar problems before?

Thank you for any advice you can give.

Kind regards
Ollowain

UPDATE:

Upon further study, I noticed that the keycloak container seems to be missing a ressource file from the keycloak.v2 admin theme:

404: /resources/cxkn4/admin/keycloak.v2/assets/main-BeZMleLO.js

Could that explain the above mentioned behaviour and how would i go about fixing it?

Regards
FSeifer

UPDATE:

I solved the issue!

Should anybody else run into his issue, I finally realized that I had been using Port 9000 for the keycloak http endpoint.

via http-port=9000

Turns out since Keycloak 25 the Port 9000 is used as the default port of the management interface
see: Release Notes

After switching the http-port from 9000 back to 8080 all worked as expected.

Although I am surprised that the server startet in the first place while the front-end port and the management port were identical. Seems worth a bug ticket.

Regards
Ollowain