How to change path to admin console?

This post was flagged by the community and is temporarily hidden.

+1 to this. After switching to Quarkus (a welcome change overall) some settings has been scattered and adminUrl is one of them.

Documentation is not really up to date on the new structure.

1 Like

This post was flagged by the community and is temporarily hidden.

I just tried this url after reading a few random posts on the interZones about Keycloak on K8s:

/dev/poc-keycloak/realms/master/account

I get the following screen:

I am missing three CSS files…

I am stumped at the moment as to how I can fix this…

Hi,

can you try setting the following property in addition to keycloak.adminUrl
-Dkeycloak.frontendUrl={{ you base keycloak host}} / auth

Hi @zak ,

I tried your suggestion but it did not work.
As I understand it (and I would love to be wrong), one cannot set up Keycloak to expose the Admin console. That has to be accessed internally.

Anyways, my reverse proxy (nginx) gave me a lovely 404 message when trying to add /admin to the frontend url.