How to setup keycloak google authentication for xamarin mobile application


I have setup keycloak server to accept google authentication. It works very well through web browser.

But when I try through my mobile application created in Xamarin, I get an errero message from google saying:

Authorisation Error: 403 disallowed_useragent

Someone have an idea what I should do on keycloak side or google side to allowed it ?

Thank so much for help

I don’t know how much this would help, but I made this library

Thank you @edewit

It looks it comes from the browser version used by WebView.

now I need to find out how to set it in Xamarin :slight_smile:

Right it’s using the web settings, you should use installed application in the google console. I have a video with how I set it up: Auth2 demo - YouTube

Wait I think there is a xamarin version as well: GitHub - aerogear-attic/aerogear-xamarin-sdk

Thank you so much for your support.

I’m lost with the file you give to me GitHub - aerogear-attic/aerogear-xamarin-sdk

I’m a nooby in Xamarin and Keycloak too, what should I do with this file?

The Auth package is split up into a core and iOS and android specific implementation for keycloak, I think with a little bit of copy paste you can use it in your xamerin project.

But if you don’t want to you can do it yourself as well. The problem you showed with google is that they use the wrong redirect / application type because you need to be redirected to you app so you need to configure the redirect to be your appId.