Is it possible to configure SSO Session Idle/Max with keycloak-operator?

I’m trying to replace an old bare metal Keycloak instance with a new one using the keycloak-operator on Kubernetes. Everything works fine, but I could not find any sign that ssoSessionIdleTimeout and ssoSessionMaxLifespan are configurable through the Operator.

According to the Operator source code (where there is no reference to either of these attributes) and the structure of a sample realm-export.json file, the logical place for these attributes is at spec.realm.ssoSessionIdleTimeout and spec.realm.ssoSessionMaxLifespan in the Keycloakrealm CRD, but this is not the case.

Are these options not configurable through the Operator CRDs, and the API is the only way to automate setting them, or am I looking at the wrong place?

1 Like

@ChyZma did you ever find a solution to this?

Unfortunately, I couldn’t find any solution using only the operator. My workaround was to configure these setting via the API (Keycloak Admin REST API) after the initial realm creation (which is done with the Operator CRD).