Keycloak 16.1.1 ALB+EC2 Invalid redirect uri for “Valid Redirect URIs with https://*”

I am having problem.

ALB + EC2 (keycloak-16.1.1)

ALB 443 → 8080

EC2
tar zxfvp keycloak-16.1.1.tar.gz -C /opt

standalone.xml add standalone.xml proxy-address-forwarding=“true”

/opt/keycloak-16.1.1/bin/standalone.sh -Djboss.htttp.port=8080

keycloak cleint page while adding “https://" on the “Valid Redirect URIs” field. https://xxxxx.xxxxx.xxxx/tokkenget

I am getting “Invalid redirect uri”

keycloack server.log redirect_uri=http://xxxxx.xxxxx.xxxx/tokkenget

In the configuration, I set https, but the response from keycloak returns http.
From Keycloak, I want you to redirect by https.
Is there any way to deal with this?

I solved this problem by myself.

In the Valid Redirect URIs setting, it was necessary to set both http and https.

Valid Redirect URIs

https://xxxxx.xxxxx.xxxx/tokkenget
http://xxxxx.xxxxx.xxxx/tokkenget