Keycloak 17 - No SSSD Federation Provider option

I installed kc 17 similar to my kc 15.0.1
In 15.01 I have the sssd option in the federation provider dropdown.
In kc 17 I don’t have this option.

Is this a bug in keycloak 17 or is my configuration wrong?
Does anybody see this option?

I installed kc 17 on Debian 11, AlmaLinux 8.5 and Fedora 35 with the same result.
No sssd option for federation provider

As I mentioned in my previous post I had no problems with kc 15.0.1

I solved my problem.
The sssd federation provider option is now available in my installations with AlmaLinux 8.5 and Fedora 35

I installed kc 17 using the existing database from my kc 15.0.1 installation.

My solution was:
stop keycloak
create a new empty database
edit /opt/keycloak/conf/keycloak.conf to use this empty database
start keycloak in dev mode: bin/kc.sh start-dev
stop keycloak
edit /opt/keycloak/conf/keycloak.conf to use the original database from my kc 15.01 installation
start keycloak in production mode: systemctl restart keycloak (bin/kc.sh start --auto-build --spi-connections-jpa-default-migration-strategy=update)

open admin console, go to user federation, sssd option is available

I did this with my Fedora 35 installation and could not believe that this was the solution.
So I did these steps again with the AlmaLinux 8.5 installation and it is also working.