Keycloak 19 XA transaction

Hello
I have a problem with XA transactions in 19.0.1. During the build process the parameter “–transaction-xa-enabled=false” is added. This works fine in version 18 but in version 19 it’s like this parameter is ignored.

Thanks for any help.
Lukas

1 Like

At the end it is working. I didn’t notice the ‘–optimized’ switch. If it is added, then everything works.

I only found this out after I got XA working on msssql.