Keycloak "failed to fetch" or "NetworkError"

Keycloak version: 23.0.3
PVE version: pve-manager/7.2-3/c743d6c1 (running kernel: 5.15.30-2-pve)
Debian version: 11.5

We are currently running a debian on a proxmox. We tried to quickly install Keycloack with docker using what’s given in the documentation of Keycloack.

docker run -p 8080:8080 -e KEYCLOAK_ADMIN=admin -e KEYCLOAK_ADMIN_PASSWORD=admin quay.io/keycloak/keycloak:23.0.3 start-dev

Everything works fine we are able to see our keycloak web interface and access the admin login UI.

We can login and this is where things get interesting. On Chrome we get a “Failed to fetch” and on Firefox we get a “NetworkError”.

Chrome Error
TypeError: Failed to fetch
at cc (http://@IP:8080/resources/jbtqd/admin/keycloak.v2/assets/index-k_eS9LF7.js:48:296906)
at #i (http://@IP:8080/resources/jbtqd/admin/keycloak.v2/assets/index-k_eS9LF7.js:48:299331)

This is what fails to fetch for Chrome.
Network error for Chrome

Firefox Error
Instead of Failed to fetch, we have “NetworkError when attempting to fetch resource”

And has the same failure as Chrome with the serverInfo and whoami.

I really want to emphasize that this problem only occurs on proxmox as we have tried multiple linux distributions and windows. But as soon as we tried on a physical computer, keycloak worked perfectly fine. We also tried on a VMWare Player Host, and it also works fine.

This is a real problem for us as we have the need to have our servers on proxmox.

We tried changing versions of Keycloak. We did them all from 21.0.0 to 23.0.3. Some errors were different but the problem stays the same, we are unable to access what comes after the admin login UI. We tried changing the cpu model of the debian guest machine as this was anyways necessary for Docker to work on our debian.

It’s important to note that this problem occurs with the distribution powered by Quarkus and Docker.

Hello everyone, I have more information on the problem we have. We are currently using servers from supermicro. It would seem that any instance of keycloak regardless of the OS will fail on supermicro servers. What we do not understand is the fact that the webpage returns an error but in debugging console of keycloak there are no errors.

Has anyone seen a similar case/have any ideas of what is causing this problem?

Some help would be appreciated as we are still stuck. Thank you.