Keycloak v25 auth flow steps unordered

Since we’ve updated to Keycloak v25.0.1, we are noticing that the creation of the authentication flow via API modifies the step order every time.

Before the update, we were calling the endpoints in the same order that we wanted the steps to be setted. Now, even if we call the endpoints in the same order, the steps appear to be unorganised.

We tried to set the priority attributte on the step creation, but it didn’t work.

Any suggestion?

Thanks in advance.

We’ve just discovered that, when creating the auth flow steps and subflows via API, all steps are set to priority 0 though we are specifying the exact priority in the call to the endpoint, so all the steps appear in random order every time we create the auth flow.

For example, we are using bodies like this in the requests:

{
provider: “registration-page-form”
priority: 1
}

Could you check if it’s a bug or if we are missusing the API call?

We’ve just solved this issue.

Since the update, when you call the endpoint to change the permissions of a step, the endpoint is expecting the priority attribute. If it’s not preset, sets the priority to 0 by default.