Keycloak X distribution import configuration issue

Hi all,
I using Keycloak in docker container. Its works very well, no problem until here but has a little bit high resource consumption. I made some investigation and found the Keycloak-X server distribution. It based on quarkus stack instead of wildfly. The main goal of this version is consume much more less resources. So I decided to test. I could able to run it but I could not import my realm file properly. When I tried to import configurations into the server, it crashed at the first time, but if I run server again it successfully import and launch. You can see the command that I used;

./ import --file=/home/ygtysr/test/loginservice/docker/rsc/MY_REALM.json --override=false --profile=dev

So here is my question; How can I import my realm configuration during at the initial stage.
I could able to do it with on Wildfly core stack;

./ -Dkeycloak.migration.action=import -Dkeycloak.migration.provider=singleFile -Dkeycloak.migration.file=/opt/jboss/rsc/MY_REALM.json -Dkeycloak.migration.strategy=IGNORE_EXISTING

What is the corresponding command for quarkus stack.

1 Like

I have the similar problem in the project i am working on. Did you find any solution?

Best Regards,

Hey @yagizonen unfortunately I did not found any solutions, I hope community will support ASAP :slight_smile:

I’m facing the same issue, any progress update here guys?


you could use the kcdam (Keycloak Admin CLI) instead of the new (but not properly working) kc cli to import the realm.

Please check out my repository: GitHub - mgoericke/keycloak-x-importer: Import realms into Keycloak distribution x container

It’s just a simple example but it shows how you can import realms into the “Keycloak.X” on startup using kcadm. the container becomes heathy after the import of your realm

1 Like