LTS policy and supported versions, recommended versions

Hello, i didnt find this information in docs (maybe i am blind). Is there any official LTS table or minimum recommended runing verion on production, as for example node.js have? https://nodejs.org/en/about/releases/

Thank you.

Hello,

It will be very interesting indeed to know if a LTS version will be exist in a near future.

For a production point of view, LTS is very good practise.

Thanks to give us more information about this LTS Keycloak topic.

I open a question on a Mailing list too : https://groups.google.com/forum/#!topic/keycloak-user/Vb6fMogBZxc

An LTS timetable would be great. I know the devs are trying their best to have an upgrade path and document the upgrade process.

How would an LTS version factor into keycloak development? An LTS requires quite some work and thinking so the question that comes to mind is who is going to take on that work.

I know RH has a product based on Keycloak and they do offer payed support - which means and LTS version. But that is not free.

You could argue that is not in RH’s interests to have a free LTS version of Keycloak since that would make their product less attractive ( I don’t know what other features they offer). But this is purely speculation on my part.

The bottom line is that LTS requires effort - and most of the time not the fun kind of effort.

Even if an LTS is not defined, a comment about the “supported” versions would be nice. I think development work only goes into the latest major version and fixes do not get back ported.
eg an issue with KC10 may exist but not get fixed in KC9.
Am I right?