MS AD FS link stops at redirect url

Hi everyone,

I have created a SAML2.0 link between my Keycloak server and an MS active directory. When I go to my client application I am sent to Kecloak. Then I can choose to log in with the active directory link. Then I come to the login page of the active directory. When I log in there, I will be sent back (POST request) to the redirect URL of Keycloak (/auth/realms/{realm}/broker/{alias}/endpoint).

Then the problem arises, I get a 200 http status on the endpoint. But then nothing happens. I didn’t get any event logging in Keycloak (everything turned on). I get the same login form as for the login.

I have already tried everything. Different (custom) authentication flows. Settings turned on and off and tried. I removed the cache continuously.

In the meantime I am becoming despondent. I don’t get any errors or abnormal logging. I can’t find a similar problem on the internet. Maybe it’s a very simple setting. Can anyone help me?

Tanks in advance!