[solved] Keycloak 17 - does not use migrated database

I have installed keycloak 17 on Debian 11 on a new LXC Container with PosgreSQL database.
My old keycloak 15.0.1 is running in a different LXC Container with MariaDB database.

I migrated the MariaDB database with pgloader https://pgloader.io/ into the new PostgreSQL database.
I verified with pgAdmin4 that the migration was successful.

But when I start the admin console in the new keycloak 17 I don’t see any of the migrated data.
There are no errors in the log.

In the database is a table migration_model with these entries:
|35889|15.0.1|1629194534|
|wgj9l|13.0.1|1624282974|
I don’t know if this is helpful.

What can I do to make keycloak read the database entries?

Thanks for reading
Guido

I have solved it.

From pgLoader docs:
“when pgLoader loads data into Postgres, it creates and targets a new schema named after the original database”

In my case keycloak loaded the schema ‘public’ and not the migrated schema ‘keycloakdb’.

So I dropped the migrated database and did a new migration into the ‘public’ schema.