[Solved] Keycloak custom identity provider without openid scope

Hi, I wanted to add a custom identity provider in my admin panel of keycloak and I ran into some issues.

There is a Default Scopes field but it only adds scopes after “openid”. And I have an API that requires me to not pass that one or else it throws invalid scope. Is there a way to disable that behaviour of adding the default “openid” scope?

The API that requires it is Authentication | Developers | DeviantArt. It needs just “basic” scope.

EDIT: Nevermind it appears that only “Impersonate” option has that problem I can just manually create a request.

Could you elaborate on how you solved this problem by “manually creating a request”? I am trying to use an Identity Provider that only uses OAuth2.0 (no OIDC), so when the openid scope is sent it triggers an error.

I’m triggered in the same issue.
Amazon Login (OpenID) returns an error when scope=openid+profile are sent to it…