Standard flow and access type

Hi to all, I’ve a question regarding the access type and the authentication flow.
If I set in a realm the access type to public i can enable the standard flow (like the implicit flow)
With standard flow I’ve to use the code and the client secret to close the authentication flow.

the problem is that using “public” like access type is not present the credential tab, so I haven’t the client secret.

is normal?


Standard auth code flow is also possible for public clients. There’s no restriction that a client needs a clientId and secret, only the confidential clients need this. Public clients have to be properly configured with valid redirect uri’s and you SHOULD enable and enforce PKCE, this makes it more secure.

Don’t use implicit flow at all, it’s strongly discouraged as it is considered insecure as of todays knowledge.


Thanks for reply! maybe I’m missing something. If I configure a client to use the standard flow, then i’ve to configure my client to send the response type “token code”. using “token code” I can retrieve from the authorization server only the code and not the access token. with the code and without the secret I can’t retrieve the access token.
for example using the oidc debugger site and setting like response type code I correctly retrieve from my keycloak server only the code that I’ve to spent again with authorization server to retrieve the access token. but since I’m i public client I’ven’t the secret to use with the code. I don’t know If I’ve explain it well.


Do you have idea how to enforce PKCE flow for public client in the Keycloak, please? I’m not able to find any config for that, so I’m curious how to force it. Thanks.

Ok, I’ve search on internet. keycloak is already pkce compliant, you have to select public, standard flow and eventually the Proof Key for Code Exchange Code Challenge Method in advanced settings. Client side the call to keycloak should include the appropriate parameters like code_challenge.

thanks for clarifications

1 Like

@nestle2377 already found it… :slightly_smiling_face:
It‘s located in „Advanced Settings“: