Unable to update provider id of requiredActions

Hi,

currently it’s not possible to update a provider id of requiredActions.

Is there a reason?