User Profile tab not available

Hey guys.
I’m starting to get to know Keycloak. I need to add new fields and hide two other fields (First Name and Last Name) in the user registration. They told me that I would have to access the “User Profile” tab in “Realm Settings”. Unfortunately, on my Realm Master, this tab is not available to me in version 22.0.3 of Keycloak. Please, can anyone help me with this issue?

You need to enable the features DECLARATIVE_USER_PROFILE and ACCOUNT3 to be able to switch the Declarative User Profile option on in the desired realm settings page:
Bildschirmfoto 2023-10-17 um 20.27.21
After enabling this, the tab “Profile” will occur.

Remember that this feature is still a PREVIEW feature (but should soon become supported).

But most probably you won’t do this in the master realm! Never use the master realm for functional purposes, only for administering and managing Keycloak itself. Create a new realm for functional/business purposes!

2 Likes

Hello Dasniko.

Thank you for your feedback.

I’m using wsl on windows 10, the command would be like this:
build --features=“declarative-user-profile,account3” ?

Taking advantage of the space, would you be able to enable the resources in my docker-compose.yml?

Just in time… to complement my last question above, I ran the following docker-compose.yml file:

services:
  keycloak:
    build:
      context: ./keycloak
      dockerfile: Dockerfile
    environment:
      - KEYCLOAK_ADMIN=${KEYCLOAK_ADMIN}
      - KEYCLOAK_ADMIN_PASSWORD=${KEYCLOAK_ADMIN_PASSWORD}
      - KEYCLOAK_FEATURES=account3,declarative-user-profile
      - DB_VENDOR=mysql
      - DB_ADDR=mysql
      - DB_DATABASE=keycloak
      - DB_USER=${MYSQL_USER}
      - DB_PASSWORD=${MYSQL_PASSWORD}
    command: "start-dev --log=\"console,file\""
    ports:
      - 8080:8080
    depends_on:
      - mysql
    networks:
      - app-network`

, in an attempt to enable my features, but unfortunately, when opening the Real settings, the User Profile tab does not appear (see image ) :

. I appreciate any help

Multiple issues…

  • From the env vars used: which Docker image do you use? It seems that you are not using the official one from Keycloak itself!? Or you are using completely wrong env vars (mostly the legacy ones) for the current image.
  • As mentioned in my previous post, the tab only occurs, when you first switch the usage of declarative user profile to “on” on the “general” tab of your realm. Do you have this switch on the “general” tab?

I’m not able to do anything in your docker-compose.yml, it’s your file, not mine.

Good morning, dasniko.

Thank you for your feedback.

First of all, I would like to apologize for my bad English and for posting a lot of problems here.

Answering your first question “which Docker image do you use? It seems that you are not using the official one from Keycloak itself!?”. The keycloak image is described in a Dockerfile inside my container like this:“FROM quay.io/keycloak/keycloak:latest

And I also use “.env.local” where my environment variables are included.

  1. Answering “Do you have this switch on the “general” tab?”. No, I do not have the “User Profile Enable” option available in the Realm general tab. She doesn’t appear to me.

  2. I’m not able to do anything in your docker-compose.yml, it’s your file, not mine.”. Please forgive me for not formulating my question correctly in English. I meant would it be possible for you to help me configure my “docker-compose.yml” file, to enable the features I need.

Can you help me resolve these issues mentioned above?

This is the general screen of my Realm:

If the toggle for user profile doesn’t show up in the Administration Console there is something going wrong passing in the features when starting the Keycloak server.

Looking at your docker-compose.yml I am seeing a KEYCLOAK_FEATURES environment variable. But as far as I know this isn’t a variable that is used anywhere. I’d instead recommend you pass the features in when running start-dev:

command: "start-dev --log=\"console,file\"" --features=\"account3,declarative-user-profile\""
1 Like

Thank you very much jonkoops.
I am really happy. It worked!! Followed his instructions and everything worked out fine. I can now see the “User Profile Enable” option. I would also like to take this opportunity to thank dasniko for his help.

2 Likes

Happy that it works for you.

But I also heavily recommend that you overhaul all of your use environment variables, as it seems that you are using not the proper ones!
For a start, read this and for all config options, read that.

1 Like

Thanks for your support, dasniko.

I will read the material you gave, about environment variables. I have difficulty applying these environment variables to the docker-compose.yml file or executing them by command using wsl2 on Windows. With this material you are giving me, I will study the subject better. Have a blessed day.