Unbound variable errors running Keycloak as Kubernetes deployment

I used to run Keycloak in my Kubernetes Cluster with this deployment configuration: https://github.com/ChristofSchwarz/qseok_on_minikube/blob/master/keycloak/keycloak-depl-persist.yaml As of yesterday (with the latest update) the pod crashes complaining about env variables not being bound:

kubectl logs --selector app=keycloak

Error Message:
/opt/jboss/tools/docker-entrypoint.sh: line 47: KEYCLOAK_FRONTEND_URL: unbound variable

I tried to create this variable, then the next and the next and the next … which it complains missing, but even with all variables were defined in my .yaml it still fails. Why is this and how can I get Keycloak run with default assumptions for missing variables as before?

There was recent base image switch (from tag 7.0.1): https://issues.jboss.org/browse/KEYCLOAK-10059
You can try to use image with previous base image tag 7.0.0 for now + report your issue.

It looks like you are using latest (8.0.0) image and not 7.0.1. Problem: https://github.com/keycloak/keycloak-containers/commit/e6544c30a4c5ff6d131cf98981e2a31f12522303#diff-8f2c471edf89dff2f216a5ee79d5b2ea

8.0.0 and latest are now rebuilt with fixes for this issue

The same error still occurs with the newest keycloak version 8.0.0. Even if all docker caches are removed…