Using curl or POSTMAN results in Could not find resource for full path

When using Keycloak 15, I was able to POST to the URL and receive an access token but now I am using Keycloak 17 and I keep getting “Could not find resource for full path.”

I use the URL: http://localhost:8080/auth/realms/myrealm/protocol/openid-connect/token
I send the grant_type=client_credentials, client_id, client_secret and scope.

What setting am I missing? In 15 I only needed to enable service accounts but even with that in 17 it does not work. Any help is appreciated.

Keycloak 17 has changed the default context path, it’s now / instead of /auth.
So, either change your URL or add --http-relative-path=/auth/ to your params (but beware - it’s a build time property!).

1 Like

Thank you! That did the trick.