Build of 12.0.1 failing

Attempting to build the 12.0.1 version and have used various commands on both the git image as well as the zip file download.

I have tried both the mvn clean install and the mvn clean install -Pdistribution commands with the same error.

It is erroring out on the quarkus server extension line of the build.

Unsure if Im missing a configuration on my side or not.

i have the same also on 12.0.0, my error was that i first had to build missing module, due to wrong order in build. so it happens at a first build.
So locally i can fix by building the module it complains about, and the a full build.
however when we build on gitlab don’t know how to fix because a build doen’t use a global repository.

Thank you rvanderboom. Nice to know its not just me as it usually is.

In terms of building just the failed module, how did you accomplish that? Did you run a maven command for just that project or did you build it through and IDE?


sorry for the late response, was very busy this week…
Locally i run the mvn command (command line) in the module(s) it was complaining about.
This way my local repository builded up with the missing dependecies…
However i liked to get it working in gitlab, this i did not manage :frowning: