Internal server error when updating profile

We use Keycloak in docker behind nginx proxy to protect our application.
We’ve been using Keycloak without problems for several months. Recently we migrated to the latest Keycloak (11.0.0) and imported all of the data from our old Keycloak server. Just today we also updated it to the latest version (11.0.1).
We started experiencing a problem regarding the user account page. We do not know when this problem began occuring, whether it was after migration or after updating to the version 11.0.1.
The problem is that when a user visits their account page (/auth/realms/{realm_name}/account) they correctly see all of their data, however if they wish to update it by pressing Save, or even Cancel it, they get an Internal Server Error. If we check the request, the server responds with 403 Forbidden status for the POST request to /auth/realms/{realm_name}/account.
Normally we would just check the logs and get a hint there, however there are no error logs on the Keycloak server. Even enabling all logging did not help at all and we do not get any info from the logs.

Any idea why the updating wouldn’t work as well why there are no logs regarding the matter?


Hi izakgl, I’m having the same problem with version 11.0.1 and 11.0.2 with a clean install (without data migration). Version 11.0.0 works fine.

Did you find any solution?

We had the same issue on a fresh deployment on version 11.0.1 and also noticed that it works correctly after downgrading to 11.0.0.

My suggestion is to just stay on the version 11.0.0 until they resolve this issue.

1 Like

I just read the issues solved in version 11.0.2 and they fixed the bug. I just tested it, and it works fine. I thought I was using version 11.0.2 but I guess docker pulled version 11.0.1.

I never had the time to test version 11.0.2. Thank you for confirming that it works now.