Keycloak 17.0.1 throws exception for No query defined for that name for named query in custom JPA

Hi team,

We were using keycloak 17.0.1 legacy up till now and now migrating to QuarkUS. we are getting following exception for named query in custom JPA provider. we copied a jar in ‘providers’ folder and it got detected as provider and did create a tables in DB. But when we try to run the rest endpoints its unable to recognise custom entity we have written in custom JPA. Can anyone please help in this if I’m missing any configurations ?

2022-04-22 08:54:46,557 ERROR [] (executor-thread-0) Uncaught server error: org.keycloak.models.ModelException: java.lang.IllegalArgumentException: No query defined for that name [findConfigByRealm]
keycloak | at org.keycloak.connections.jpa.PersistenceExceptionConverter.convert(
keycloak | at org.keycloak.connections.jpa.PersistenceExceptionConverter.invoke(
keycloak | at com.sun.proxy.$Proxy75.createNamedQuery(Unknown Source)

Same error we are getting for domain-extension-example .


Hi @prachi.pachankar

Did you find any resolution for this? We are getting the same error so wanted to check.