Keycloak 20.0.1 install on server w/o GUI

I am following the getting started guides but have no luck initially accessing the admin console to setup my installation of Keycloak 20.0.1. The guides all suggest opening localhost with port 8080 which is not possible when you install Keycloak on a server - opening the URL via lynx on the CLI does not work as the welcome page loads, but navigating to the Admin Console says: “You need JavaScript”.

Wondering why Keycloak install guides do not consider someone installing this thing on a regular server without having access to a GUI I moved on setting up a reverse proxy to make localhost available under a URL I can actually open in a regular web browser:

What I did:

  • set up nginx reverse proxy with ssl, so localhost on port 8080 is exposed via a subdomain on mydomain dot com using https (I cannot post URLs here as a newbee)
  • run Keycloak via docker: docker run -p 8080:8080 -e KEYCLOAK_ADMIN=admin -e KEYCLOAK_ADMIN_PASSWORD=admin Quay start-dev --proxy edge
  • I also tried w/o the --proxy param

Result is:

  • I can see the Keycloak welcome page under my domain (via https)

  • I see the link to the “Administration Console” goes to “” (thought the --hostname param would change this?)

  • I try to manually navigate to “[mydomain]/admin/” which redirects me to “[mydomain]/admin/master/console/” and displays a spinner with message “Loading the admin console” staying there until eternity

  • There’s an “Uncaught in Promise” on the JS Console in the Browser with a Message “Timeout when waiting for 3rd party check iframe message.”

As I am out of bullets now: can someone pleas provide pointers how to initially set up Keycloak 20.0.1 on a regular server CLI only? … or at leas how to access the admin console? Thank you!

I get the same error as you on every version above 18.02 i’ve tried.