Keycloak X - Custom Idenity Provider Templates

I’m currently working on a custom identity provider for keycloak-x (the quarkus based distribution of keycloak), using the projects listed on the extension page as template:

Everything works as expected with keycloak-x, only it seems that the folder where additional templates (partials) are kept is ignored:
This behavior is the same with existing extensions like

When i got to “Identity Providers” and select one of the custom ones, keycloak returns “Resource not found …” (GET /resources/14.0.0/admin/keycloak/partials/realm-identity-provider-franceconnect-particulier.html)

As a workaround i have to compile a custom admin theme, adding the partials to the theme. This however will become problematic once you need multiple custom providers, since you can only select one custom theme for the admin area.

Can you tell me how i can add templates to my provider without creating a custom theme?

Packaging the templates with the provider seems to have worked with the regular wildfly based keycloak distribution, but not with keycloak-x.

PS: I would have provided more examples, but i can only add 2 links…

In Keycloak-X it only works with a jar file. For more, see Deploying Themes

Thanks, I known. I am using jar files and have read the docs.

Did you manage to make it working with keycloak.x ? I asked the same thing here, but no response :slight_smile:

Hi @micedre,
No, unfortunately I still don’t have a solution…

I am running into pretty much the same issue. This has worked in previous versions i.e Keycloak 15.0.0.

This appears to be a bug in Keycloak.X

I have two providers I use one from [GitHub - BenjaminFavre/keycloak-apple-social-identity-provider: Apple Social Identity Provider for Keycloak](, and I wrote another custom provider.

The custom templates are housed under myprovider.jar\theme-resources\resources\partials, just as they should be packaged.

Bear in mind I do run kc.bat build after placing both the jar files in the keycloak-17.0.0\providers folder.

When editing configured providers using say following links below I get 404 on one of them unless I remove one or the other, or place the template files in keycloak-17.0.0\themes\base\admin\resources\partials to prevent 404 message



In Keycloak version 15.0.0 when browsing to /admin/master/console/#/server-info/providers under section I see

themeResource	 apple-social-identity-provider-1.0.2.jar

In Keycloak version 17.0.0 when browsing to /admin/master/console/#/server-info/providers under section I see

themeResource	classpath