Run Keycloak with database contains data

i configured keycloak with mysql database and it worked,
i created a realm, user, role for test and everything was fine,
I stopped keycloak and restarted it with >standalone.bat
and i got this error:

FATAL [] (ServerService Thread Pool – 65) Error during startup: java.lang.RuntimeException: Exception invoking method [listUnrunChangeSets] on object [liquibase.Liquibase@f0132b4], using arguments [null,(),false]

if i delete the database and recreate it and run keycloak it will work but run it with database contains data the error above will appear

Please help me to solve this error. Thank you.

@mshushkov @MoroccanGeek @Nikhiljbhandari @dasniko , @mkanis , @bathe , @pkadian , @anish @Gen
if you have any clues, please help me to solve this problem

Finally, I found the solution
at the beginning i had the newest version of mysql-connector-java it’s 8.0.23
i replaced it with an old version 8.0.21 and boom it worked

ps: of course I modified the file module.xml


Hi aggoun

Thank you so much, this was same with me, managed to get this closed.