Show Real IP address of client on the keycloak events

Ingress controller configuration:

>   annotations:
>     kubernetes.io/ingress.class: nginx
>     nginx.ingress.kubernetes.io/configuration-snippet: >
>       proxy_set_header X-Forwarded-For $proxy_protocol_addr; proxy_set_header
>       X-Forwarded-Proto $scheme;
>     nginx.ingress.kubernetes.io/proxy-buffer-size: 24k
>     nginx.ingress.kubernetes.io/rewrite-target: /$1

Keycloak configuration:

> spec:
>   DisableDefaultServiceMonitor: true
>   externalDatabase:
>     enabled: true
>   instances: 3
>   keycloakDeploymentSpec:
>     experimental:
>       env:
>         - name: JBOSS_JAVA_SIZING
>           value: '-Xmx512m -Xms64m -XX:MetaspaceSize=96M -XX:MaxMetaspaceSize=256m'
>         - name: JAVA_OPTS_APPEND
>           value: ''
>         - name: JAVA_OPTS
>           value: ''
>         - name: PROXY_ADDRESS_FORWARDING
>           value: 'true'

Keycloak version 18.0.2-legacy
Keycloak operator version 18.0.2-legacy
Ingress-nginx-controller version 1.3.0
But I still see the

1 Like

Have you find a solution?