Blank Admin Console

Hello,

I am delpoying keycloak on a Fargate Task in AWS. I managed to run the task and the provided DNS Adress gets me to the Keycloak Landing Page. However, when I clock on the Admin Console (/auth/admin/master/console/) I get a blank page and no error is shown or logged.

Does anyone know what could be causing this problem?

I solved it by adding PROXY_ADDRESS_FORWARDING=true to the enviroment variables.

3 Likes

@jominga

I am facing a similar issue running it in an ECS cluster (EC2 launch type) behind an application load balancer.

I came across the below documentation, where it is suggested to add this variable
proxy-address-forwarding="true"
to the keycloak configuration standalone.xml or domain.xml.

Just wanted to ask you whether all you have done is just add that environment variable to the Fargate task and didn’t change anything in the standalone.xml.

Thanks in advance

@jominga
Don’t bother. I just got it working just by adding that environment variable as you mentioned. Thanks.

How to set this without Docker environment variables?

I tried using proxy=edge in keycloak.conf but still result in a blank page upon trying to browse /admin.

+1 for me. Where is this variable added without docker?

1 Like