Not able to start KeyCloak

I just downloaded KeyCloak, went to getting started and started server using sh ./ I am on Ubuntu 18 with OpenJDK 11.0.10

After executing i see standard output and the last 2-3 lines that I see are as below but still not able to access the Admin Console on browser.

17:04:54,865 INFO [org.wildfly.extension.undertow] (MSC service thread 1-1) WFLYUT0006: Undertow HTTP listener default listening on
17:04:54,947 INFO [] (MSC service thread 1-1) WFLYEJB0493: EJB subsystem suspension complete

17:04:55,122 INFO [org.wildfly.extension.undertow] (MSC service thread 1-4) WFLYUT0006: Undertow HTTPS listener https listening on

17:05:02,033 INFO [] (Controller Boot Thread) WFLYSRV0212: Resuming server
17:05:02,035 INFO [] (Controller Boot Thread) WFLYSRV0025: Keycloak 12.0.4 (WildFly Core 13.0.3.Final) started in 10141ms - Started 589 of 867 services (585 services are lazy, passive or on-demand)
17:05:02,036 INFO [] (Controller Boot Thread) WFLYSRV0060: Http management interface listening on
17:05:02,036 INFO [] (Controller Boot Thread) WFLYSRV0051: Admin console listening on

  • I checked the process and the process is running on the server.
  • I executed netstat to see the ports and they too are listening.
  • I tried telnet from my machine and i was not able to. Then i changed firewall rules and added all the required ports.
  • I shutdown the KeyCloak service and started an nc on port 8080 to check whether this port is listening, i could able to telnet from my local machine.
  • I started the services back and again tried to telnet on port 8080, i was not able to.

So it seems the ports aren’t an issue but it seems service is, can somebody guide me what wrong i am doing?

You can try:

1.) cd /opt/keycloak/bin

2.) sudo ./ -b


sudo ./ -b -bmanagement &

Great…it worked. Thanks for the advice.

1 Like

You’re welcome! @pshukla