Unable to connect to Wildfly using 9990 port

I have installed and configure Keycloak server on my VM instance and keycloak is running successfully on http://X.X.X.X:8080. Also, I had configured wildfly on the same VM as per the documentation but when I am trying to access it using http://X.X.X.X:9990 its showing me “This site can’t be reached. X.X.X.X took too long to respond.” error. I have also check my standalone.xml file and its fine. I have checked all access protocol properly for the VM but still failed. I do same steps on my localhost and on another VM and both Keycloak and Wildfly running fine. I have tried a lot but unable to troubleshoot it. Does anyone know this type of circumstances or faced same issue for the same? Thanks in advance for the help!

How are you running Keycloak? From the Docker image, or using the standalone distribution? You may need to make sure the management interface is bound to an IP address. If you’re using the standalone distribution, you can just add a parameter -bmanagement= to the startup script.

If you want to access the management port from somewhere else than localhost, edit the following to your standalone.xml (located in /KCHOMEDIR/standalone/configuration):

    <interface name="management">

Shutdown your server before editing the file. If a shutdown is not possible you should use the Jboss CLI.

If you are running Keycloak with Docker, edit the standalone-ha.xml. In that case also make sure that your 9990 port is exposed via Docker.

Also check your firewall settings: you should consider whitelisting for access to the management port

Hi, Thanks alot! It helps me and running successfully now.

Hi, I have tried both solutions and it saves my lot of time. Thanks alot!